Amsn 0.98b con antialiasing e Drag&Drop da SVN

ATTENZIONE:

Prima di seguire questa guida leggere attentamente questo avviso!!!

E’ probabile che lo script usato nella guida installi le tcl/tk 8.6 che non sono compatibili con l’ultima versione di aMsn (alcune funzioni della nuova versione delle tcl/tk hanno prototipi diversi) in questo caso leggere i commenti sotto su come risolvere il problema a breve posterò una guida su come installare aMsn 0.98 con antialiasing alternativa. Scusatemi per il disagio. A presto!!

Ragazzi finalmente una degna versione di aMsn che prende il meglio del client M*c**soft a cui si ispira… ma bando alle ciance e arriviamo al dunque da terminale eseguiamo i seguenti comandi…:

wget http://repo.intilinux.com/fixamsn.tar.gz

tar zxvf fixamsn.tar.gz

(Attenzione: viene disinstallato amsn e tutti i suoi dati per effettuare una copia di backup di .amsn diamo il comando

mkdir amsn-old && cp -a .amsn/ amsn-old/ )

bash fixamsn.sh clean

sudo apt-get install amsn

bash fixamsn.sh cvs

Lo script ha bisogno di essere seguito dall’utente poiché esegue comandi con sudo e si metterà prima o poi in attesa di password… tra l’altro ogni qual volta vorrete aggiornare la vostra versione di aMsn vi basterà ridare il comando dalla vostra home “bash fixamsn.sh cvs”.

Se volete aggiungere anche il Drag&Drop dei file nelle finestre di chat:

cvs -z3 -d:pserver:anonymous@tkdnd.cvs.sourceforge.net:/cvsroot/tkdnd login

cvs -z3 -d:pserver:anonymous@tkdnd.cvs.sourceforge.net:/cvsroot/tkdnd co -P tkdnd/lib

sudo mkdir /usr/share/amsn/utils/tkdnd

sudo cp tkdnd/lib/*tcl /usr/share/amsn/utils/tkdnd/

sudo cp tkdnd/lib/Linux/libtkdnd1.0.so /usr/share/amsn/utils/tkdnd/

Annunci

20 Risposte

  1. mmm…quando parte lo script si blocca sul login all’indirizzo sourceforge per scaricare il tc (Logging in to :pserver:anonymous@tcl.cvs.sourceforge.net:2401/cvsroot/tcl
    ) l..! come posso fare??

  2. @fabbio:

    premi semplicemente ENTER è un login anonimo al server….

  3. c’è poco da fare,rimarrò sempre un niubbo..:D

    grazie mille! 🙂

  4. ottima guida, complimenti!

  5. […] Fonte: nonsololinux’s blog […]

  6. Scusa puoi dare un’occhiata mi è successo quando ho tentato l’aggiornamento http://pastebin.ubuntu-nl.org/61849/

  7. @Emanuele:

    ma hai seguito la mia guida?

  8. Si ho seguito la tua guida. Amsn è installato ma siccome ho riscontrato un bug ieri ho tentato di fare l’aggiornamento di amsn eseguendo solo l’ultimo comando come dice la tua guida.

  9. che tipo di bug? se hai saltato qualke passaggio può essere che non hai le librerie di sviluppo per una corretta cmpilazione teoricamente lo script dovrebbe installarti tutto lui… che ubuntu hai?

  10. Il bug è che quando mi inviano un primo file mi esce la richiesta lo accetto e va bene. Il secondo file che tentano di inviarmi non mi esce nessuna doanda vuoi accettare il file, ma mi si apre un’altra finestra vuota a linguetta nella stessa finestra di conversazione. Ho ubuntu gutsy. Ho visto che lo script cerca di installare le tcl/tk 8.6

  11. Hai provato ad aggiornare? Dimmi a te cosa succede 🙂

  12. è strano che tu debba accettare per l’invio del file… a me non chiede nulla
    l’aggiornamento lo lancio ogni settimana “bash fixamsn.sh cvs” mi va tutto liscio… dall’errore che mi hai indicato nel link non si capisce bene cosa accade…non so che dirti

  13. Il file che intendevo io era quello che per esempio un mio amico mi invia il primo va bene, ma se me ne invia un altro ancora mi esce il problema.

  14. Aaaah capito capito… ma questo bug te l’ha cominciato a dare in seguito a cosa? Cioè , alla prima installazione di amsn seguendo la mia guida ti aveva mai dato questo problema del trasf file??

    Assicurati che sia installata un’unica versione delle tcl/tk…

    Per quanto riguarda il problema durante l’aggiornamento appena ho un pò di tempo provo a farlo anche io e vedo come va…

  15. Per il trasferimento file credo sia un bug di amsn infatti i primi file che ti mandano vanno bene ma se te ne mandano 3 o 4 uno dopo l’altro si presenta il problema. Purtroppo per le librerie tcl/tk devo per forza averne 2 le 8.4 anche in quanto xchat funziona solo con quest’ultime e non credo che dipenda da questo perchè quando amsn viene compilato gli viene indicato quale librerie utilizzare. Per evitare tutto avevo disinstallato tutte le librerie tcl/tk da synaptic e ho cancellato ogni file riguardante le librerie tcl/tk da terminale. Ho rilanciato lo script (ripetendo la guida) e questo mi ha installato le 8.4 8.5 e 8.6 (effettivamente in synaptic le 8.6 non comparivano) però nel file system erano presenti dei file come ci sono pure per le 8.4 e 8.5. L’errore sempre lo stesso e cioè che compila amsn con le 8.6. Esausto di questa situazione ho fatto di nuovo pulizia, mi sono scaricato i sorgenti delle tcl/tk8.5 le ho compilate e installate, stessa cosa con amsn svn e del pacchetto tkdnd per il drag and drop. Quest’ultimo l’ho convertito in deb perchè era in rpm. Risultato con la versione 9685 amsn svn il problema ancora persiste, ma almeno mi sono tolto lo sfizio di aggiornare.

  16. @emanuele

    ciao,
    ho appena lanciato lo script di agiornamento e mi ha dato il tuo stesso errore, mi sono ritrovato il sistema sputtanato e amsn cercava sempre di compilare con le tcl/tk 8.6… mi sono dato da fare a ripulire il tutto e sistemare i link alle librerie e ho scaricato da svn la revisione 9693… l’ho compilata con le tcl/tk 8.5 installate dal repository backports di gutsy ed è andato tutto bene… questa revisione fortunatemnte non dà problemi se vuoi provarla l’ho scaricata dando questo comando:

    svn co https://amsn.svn.sourceforge.net/svnroot/amsn/trunk/amsn amsn

    per installarla
    ./configure
    make
    sudo make install

    assicurati che dopo il ./configure risulti che ha riconosciuto come librerire le tcl/tk 8.5

    Fammi sapere ciao

  17. Ho aggiornato la guida (grazie ad Emanuele per aver segnalato l’errore) … come già detto a breve redarrò una guida alternativa all’installaizone di aMsn 0.98b con antialiasing … ho appena testato un procedimento alternativo e funziona… ho bisogno soolo di un pò di tmepo per scrivere la guida.
    Grazie anticipatamente per la pazienza

    NonSolo1x

  18. Si anch’io me lo sono scaricato da quell’indirizzo e ora se voglio aggiornarlo basta che entro nella cartella amsn e do un svn up vedo la versione ricompilo e installo. Meglio le cose manuali almeno vedi dov’è che s’inceppa se ci sono errori 😉

  19. Ti dirò di più, ho ricancellato tutto quello che riguardava le tcl/tk 8.5.0 che avevo scaricato e compilato. Sono andato sul sito di sviluppo tcl/tk e mi sono scaricato i sorgenti 8.5.2 li ho compilati e installati. Poi ho aggiornato amsn alla versione 9695 o 9693 (non mi ricordo). Ora non mi resta che divertirmi .. ciao 😉

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: